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Introducing Pivot Tables
The pivot table feature is perhaps the most technologically 
sophisticated component in Excel. With only a few mouse clicks, you 
can slice and dice a data table in dozens of different ways and produce 
just about any type of summary you can think of.

About Pivot Tables
A pivot table is essentially a dynamic summary report generated from 
a database. The database can reside in a worksheet (in the form of 
a table) or in an external data file. A pivot table can help transform 
endless rows and columns of numbers into a meaningful presentation 
of the data.

For example, a pivot table can create frequency distributions and cross-
tabulations of several different data dimensions. In addition, you can 
display subtotals and any level of detail that you want.

Perhaps the most innovative aspect of a pivot table is its interactivity. 
After you create a pivot table, you can rearrange the information in 
almost any way imaginable and even insert special formulas that 
perform new calculations. You even can create post hoc groupings 
of summary items (for example, combine Northern Region totals 
with Western Region totals). With a few mouse clicks, you can apply 
formatting to a pivot table to convert it into an attractive report.

One minor drawback to using a pivot table is that, unlike a formula-
based summary report, a pivot table does not update automatically 
when you change information in the source data. This drawback doesn’t 
pose a serious problem, however, because a single click of the Refresh 
button forces a pivot table to update itself with the latest data.

A Pivot Table Example
The example below is a table that will be converted into several pivot 
tables. I recommend that all simple tables should be converted into 
true tables by using Insert Tables > Table, but that is not a requirement 
for creating a pivot table. Then, if you expand the table by adding new 
rows of data, Excel will refresh the pivot table without the need to 
manually indicate the new data range.

This table is 
used to create 
a pivot table.

Figure 1.
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This table consists of a month’s worth of new account information 
for a three-branch bank. The table contains 712 rows, and each row 
represents a new account opened at the bank. The table has the 
following columns:

 ■ Open Bank account data only.xlsx

 ■ The date the account was opened

 ■ The day of the week the account was opened

 ■ The opening deposit amounts

 ■ The account type (CD, checking, savings, or IRA)

 ■ Who opened the account (a teller or a new-account 
representative)?

 ■ The branch at which it was opened (Central, Westside,  
or North County)

 ■ The type of customer (an existing customer or a new 
customer)

In its current form,  though, the data doesn’t reveal much. To make 
the data more useful, you need to summarize it. We need to  answer 
questions about the data. Following are a few questions that may be of 
interest to the bank’s management:

 ■ What is the daily total new deposit amount for each branch?

 ■ Which day of the week accounts for the most deposits?

 ■ How many accounts were opened at each branch, broken 
down by account type?

 ■ What is the dollar distribution of the different account types?

 ■ What types of accounts do tellers open most often?

 ■ In which branch do tellers open the most checking accounts 
for new customers?

Creating a pivot table takes only a few seconds, does not require a 
single formula, and produces a nice-looking report. In addition, pivot 
tables are much less prone to error than creating formulas.

Below example shows a pivot table created from the bank data. 
This pivot table shows the amount of new deposits, broken down by 
branch and account type. This particular summary is one of dozens of 
summaries that you can produce from this data.

A simple pivot table.

Figure 2.
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Notice the change in the orientation of the table? For this pivot table, 
branches appear as column labels, and account types appear as row 
labels. This change, which took about five seconds to make, is another 
example of the flexibility of a pivot table.

So why pivot a table?

Pivot, as a verb, means to rotate or revolve. If you think of your data as 
a physical object, pivot table lets you rotate the data summary and look 
at it from different angles or perspectives. A pivot table allows you to 
move fields around easily, nest fields within each other, and even create 
ad hoc groups of items.

If you were handed a strange object and asked to identify it, you’d 
probably look at it from several different angles in an attempt to figure 
it out. Working with a pivot table is similar to investigating a strange 
object. In this case, the object happens to be your data. A pivot table 
invites experimentation, so feel free to rotate and manipulate the pivot 
table until you’re satisfied. You may be surprised at what you discover.

Data Appropriate for A Pivot Table
A pivot table requires that your data be in the form of a rectangular 
database table. You can store the database in either a worksheet range 
(which can be a table or just a normal range) or an external database 
file. And although Excel can generate a pivot table from any database, 
not all databases benefit. Keep in mind that a database must be 
normalized to create pivot tables. In other words, each record (a row) 
contains information that describes the data.

Fields in a database table consist of two types of information:

 ■ Data: contains a value or data to be summarized. For the bank 
account example, the amount field is a fata field

 ■ Category: Describes the data. For the bank account data, the 
Date, Weekday, AcctType, Opened By, Branch, and Customer 
fields are category fields because they describe the data in 
the Amount field

A single database table can have any number of data fields and 
category fields. When you create a pivot table, you usually want to 
summarize one or more of the data fields. Conversely, the values in the 
category fields appear in the pivot table as rows, columns, or filters.

The next example shows another pivot table generated from the bank 
data. This pivot table uses a drop-down Report Filter for the Customer 
item (in row 2). In the figure, the pivot table displays the data only for 
existing customers. (The user can also select New or All from the drop-
down control.)

A pivot table 
that uses a 
report filter.

Figure 3.
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Exceptions exist, however, and you may find the Excel Pivot Table 
feature useful even for databases that do not contain actual numerical 
data fields. 

The below example shows an Excel range that is not appropriate for a 
pivot table. Although the range contains descriptive information about 
each value, it does not consist of normalized data. In fact, this range 
resembles a pivot table summary, but it’s much less flexible.

The following example shows the same data but normalized. This range 
contains 78 rows of data — one for each of the six-monthly sales values 
for the 13 states. Notice that each row contains category information 
for the sales value. This table is an ideal candidate for a pivot table and 
contains all information necessary to summarize the information by 
region or quarter.

This range contains normalized data and is appropriate for a pivot table.

This range is not 
appropriate for 
a pivot table.

To transform a table 
to a normalized 
table, use Get & 
Transform function 
in Powery Query.

Figure 4.

Figure 5.
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The below example shows a pivot table created from the normalized 
data. As you can see, it’s virtually identical to the nonnormalized data. 
Working with normalized data provides ultimate flexibility in designing 
reports.

Creating A Pivot Table 
Automatically
If your data is in a worksheet, select any cell within the data range 
Choose Insert > Tables Recommended Pivot Tables. Excel quickly scans 
your data, and the Recommended Pivot Tables dialog box presents 
thumbnails that depict some pivot tables that you can choose from. 

The pivot table thumbnails use your actual data, and there is a good 
chance that one of them will be exactly what you’re looking for — or at 
least close to what you’re looking for. Select a thumbnail, click 0K, and 
Excel creates the pivot table on a new worksheet.

When any cell in a pivot table is selected, Excel displays the Pivot Table 
Fields task pane. You can use this task pane to make changes to the 
layout of the pivot table.

A pivot table 
created from 
normalized data.

Selecting a 
Recommended 
Pivot Table.

Figure 6.

Figure 7.
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If your data is in an external database, start by selecting a blank cell. 
When you choose Insert Tables Recommended Pivot Tables, the 
Choose Data Source dialog box appears. Select Use an External Data 
Source, and then click Choose Connection to specify the data source. 
You’ll see the thumbnails of the list of recommended pivot tables.

Specifying the Location for the Pivot Table
Use the bottom section of the Create Pivot Table dialog box to indicate 
the location for your pivot table. The default location is on a new 
worksheet, but you can specify any range on any worksheet, including 
the worksheet that contains the data.

Creating A Pivot Table Manually
Creating a pivot table is an interactive process. It is not at all uncommon 
to experiment with various layouts until you find one that you’re 
satisfied with. 

Specifying the Data
If your data is in a worksheet range, select any cell in that range and 
then choose Insert > Tables > Pivot Table. 

Figure 8.

Figure 9.
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Click 0K, and Excel creates an empty pivot table and displays a Pivot 
Table Fields task pane.  The Pivot Table Fields task pane is typically 
docked on the right side of the Excel window. Drag its title bar to move 
it anywhere you like. Also, if you click a cell outside the pivot table, the 
task pane is temporarily hidden.

Laying Out the Pivot Table
Next, set up the actual layout of the pivot table. You can do so by using 
of the following techniques:

 ■ Drag the field names (at the top of the Pivot Table Fields task 
pane) to one of the four boxes at the bottom of the task pane

 ■ Place a check mark next to the item at the top of the Pivot 
Table Fields task pane. Excel places the field into one of the 
four boxes at the bottom. You can drag it to a different box,  
if necessary

 ■ Right-click a field name at the top of the Pivot Table Fields 
task pane and choose its location from the shortcut menu  
(for example, Add to Row Labels)

The following steps create the pivot table: presented earlier in this 
chapter for this example, I drag the items from the top of the Pivot Table 
Fields task pane to the areas in the bottom of the Pivot Table Fields 
task pane.

 ■ Drag the Amount field into the Values area. At this point, the 
pivot table displays the total of all the values in the Amount 
column

 ■ Drag the AcctType field into the Rows area. Now the pivot 
table shows the total amount for each of the account types

 ■ Drag the Branch field into the Columns area. The pivot table 
shows the amount for each account type, cross-tabulated by 
branch. The pivot table updates itself automatically with every 
change you make in the Pivot Table Fields task pane

 ■ Right click any cell in the pivot table and choose Number 
Format. Excel displays the Number tab of the Format Cells 
dialog box

 ■ Select a number format and click OK. Excel applies the format 
to all numeric cells in the pivot table

Figure 10.
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After a few simple steps, the pivot table shows a summary of the data.

Column 
Labels: 

Afield that has a column orientation in the pivot table. Each item in the field 
occupies a column. In the figurer Customer represents a column field that 
contai ns two items (Existing and New): You can have nested column fields.

Grand 
Totals: 

A row or column that displays totals for all cells in a row or column in a pivot 
table. You can specify that grand totals be calculated for rows, columns, or 
both (or neither). The pivot table in the figure shows grand totals for both 
rows and columns.

Group: A collection of items treated as a single item. you can group Items manually 
or automatically (group dates into months, for example). The pivot table in 
the figure does not have defined groups.

Item: An element in a field that appears as a row or column header in a pivot table. 
In the figure, Existing and New are items for the Customer field. The Branch 
field has three items: Central, North County, and Westside. AcctType has four 
items: CD, Checking, IRA, and Savings. 

Refresh: Recalculates the pivot table after making changes to the source data.

Row 
Labels: 

A field that has a row orientation in the pivot table. Each item in the field 
occupies a row. You can have nested row fields. [n the figure, both Branch 
and AcctType represent row fields.

Source 
Data: 

The data used to create a pivot table. It can reside in a worksheet or an 
external database.

Subtotals: A row or column that displays subtotals for detail cells in a row or column 
in a pivot table. The pivot table in the figure displays subtotals for each 
branch, below the data. You can also display subtotals above the data or hide 
subtotals.

Table 
Filter:

A field that has a page orientation in the pivot table —similar to a slice of a 
three dimensional cube. You can display one item, multiple items, or all items 
-in a page field at one time. In the figure, OpenedBy represents a page field 
that displays All (that is, not filtered).

Value 
Area:

The cells in a pivot table that contain the summary data. Excel offers several 
ways to summarize the data (sum, average, count, and so on).

Figure 11.
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Formatting the Pivot Table
By default, pivot tables use General number formatting. To change the 
number format for all data, right-click any value and choose Number 
Format from the shortcut menu. Then use the Format Cells dialog box 
to change the number format for the displayed data.

You can apply any of several built-in styles to a pivot table. Select any 
cell in the pivot table and then choose Pivot Table Tools > Design > Pivot 
Table Styles to select a style. Use the controls in the Pivot Table Tools > 
Design > Pivot Table Style Options group to finetune your pivot table.

You can also use the controls from the Pivot Table Design Layout group 
to control various elements in the pivot table. You can adjust any of the 
following elements:

 ■ Subtotals: Hide subtotal or choose where to display them 
(above or below the data.

 ■ Grand Totals: Choose which types, if any, to display

 ■ Report Layout: Choose from three different layout styles 
(compact, outline, or tabular). You can also choose to hide 
repeating labels

 ■ Blank Row: Add a blank row between items to improve 
readability

The Pivot Table Tools > Analyze > Show group contains additional options 
that affect the appearance of your pivot table. For example, you use the 
Show Field Headers button to toggle the display of the field headings.

Still more pivot table options are available from the Pivot Table Options 
dialog box. To display this dialog box, choose Pivot Table Tools > Analyze > 
Pivot Table > Options. Or right-click any cell in the pivot table and choose 
Pivot Table Options from the shortcut menu.

Pivot Table Calculations
Pivot table data is most frequently summarized using a sum. However, 
you can display your data using several different summary techniques, 
specified in the Value Field Settings dialogue box. The quickest way to 
display this dialogue box is to right-click any value in the pivot table and 
choose Value Field Settings from the shortcut menu.  This dialog box 
has two tabs: Summarize Values By and Show Values As. 

Use the Summarize Values By tab to select a different summary 
function Your choices are Sum, Count, Average, Max, Min, Product, 
Count Numbers, StdDev, StdDevp, Var. and Varp.

Figure 12.
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To display your values in a different form, use the drop-down control 
on the Show Values As tab. You have many options to choose from, 
including as a percentage of the total or subtotal.

This dialog box also provides a way to apply a number format to the 
values. Just click the button and choose your number format.

Modifying the Pivot Table
After you create a pivot table, changing it is easy. For example, you can 
add further summary information by using the pivot table Fields task 
pane. The example below shows the pivot table after a second field  
(OpenedBy) was dragged to the Rows section in the pivot table Fields 
task pane.

Two fields are used for row labels.

Here are some tips on other pivot table modifications you can make:

 ■ To remove a field from the pivot table, select it in the bottom 
part of the pivot table Fields task pane and then drag it away

 ■ If an area has more than one field, you can change the order 
in which the fields are listed by dragging the field names. 
Doing so determines how nesting occurs and affects the 
appearance of the pivot table

Figure 13.

Figure 14.
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 ■ To temporarily remove a field from the pivot table, remove the 
check mark from the field name in the top part of the pivot 
table Fields task pane. The pivot table is redisplayed without 
that field. Place the check mark back on the field name, and it 
appears in its previous section

 ■ If you add a field to the Filters section, the field items appear 
in a drop-down list, which allows you to filter the displayed 
data by one or more items. The below example shows that the 
Date field was dragged to the Filters area. The pivot table is 
now showing the data only for a single day (which I selected 
from the drop-down list in cell Bl)

Copying A Pivot Table’s Content
 ■ A pivot table is flexible, but it does have some limitations. For 

example, you can’t add new rows or columns, change any of 
the calculated values, or enter formulas within the pivot table. 
If you want to manipulate a pivot table in ways not normally 
permitted, make a copy of it so it’s no longer linked to its data 
source

 ■ To copy a pivot table, select the entire table and choose 
Home > Clipboard Copy (or press Ctrl+C) Then activate a new 
worksheet and choose Home Clipboard > Paste > Paste Values. 
The pivot table formatting is not copied — even if you repeat 
the operation and use the Formats option in the Paste Special 
dialog box

 ■ To copy the pivot table and its formatting, use the Office 
Clipboard to paste- [f the Office Clipboard is not displayed, 
click the dialog box launcher in the bottom right of the Home > 
Clipboard group

 ■ The contents of the pivot table are copied to the new location 
so that you can do whatever you like to them.

 ■ The copied information is not a pivot table, and it is no longer 
linked to the source data. If the source data changes, your 
copied pivot table will not reflect these changes

Pivot Table Examples
What is the daily total new deposit amount for each branch?

 ■ Place Branch field in the Columns section

 ■ Place Date field in the Rows section

 ■ Place Amount field in the Values section and is  
summarized by Sum

Note that the pivot table can also be sorted by any column. For 
example, you can sort the Grand Total column in descending order to 
find out which day of the month had the largest amount of new funds. 
To sort, just right-click any cell in the column to sort and choose Sort 
from the shortcut menu.
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This pivot table shows 
new account totals by 
day of the week.

Which day of the week accounts for the most deposits?

 ■ The Weekday field is in the Rows section

 ■ The Amount field is in the Values section and is  
summarized by sum

 ■ Add conditional formatting data bars to make it  
easier to see how the days compare. As you see,  
the largest deposit days are Fridays

How many accounts were opened at each branch, broken down by 
account type?

 ■ The AcctType field is in the Columns section

 ■ The Branch field is in the Rows section

 ■ The Amount field is in the Values section and is summarized 
by Count by right-clicking any cell in the Values area and 
choose Summarize Values By > Count

What is the dollar distribution of the different account types?

Figure 18 shows a pivot table that answers this question. For example, 
253 (or 35.53%) of the new accounts were for an amount of $5,000 or 
less.

Figure 15.

Figure 16.

Figure 17.
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This pivot table is unusual because it uses only one field: Amount.

 ■ The Amount field is in the Rows section  
(grouped, to show dollar ranges)

 ■ The Amount field is also in the Values section and is 
summarized by Count

 ■ A third instance of the Amount field is the Values  
section, summarized by Count and summarized by  
Percent of Column Total

When the Amount field was initially added to the Rows section, the 
pivot table showed a row for each unique dollar amount. To group the 
values, right-click one of the Row labels and chose Group from the 
shortcut menu. Then use the Grouping dialog box to set up bins of 
$5,000 increments. Note that the Grouping dialog box does not appear 
if you select more than one Row label.

The second instance of the Amount field (in the Values section) is 
summarized by Count. Right-click a value and chose Summarize Data By > 
Count from the shortcut menu.

Add another instance of Amount to the Values section, and set it up to 
display the percentage. Right-click a value in column C and chose Show 
Values As > % of Column Total. This option is also available in the Show 
Values As tab of the Value Field Settings dialog box. 

The pivot table below 
shows that the most 
common account 
opened by tellers is a 
checking account.

What types of accounts do tellers open most often?

 ■ The AcctType field is in the Rows section

 ■ The OpenedBy field is in the Filters section

 ■ The Amount field is in the Values section  
(summarized by Count)

 ■ A second instance of the Amount field is in the 
Values section (summarized by % of Column Total)

Figure 18.

Figure 19.
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This pivot table uses the OpenedBy field as a filter and is showing 
the data only for tellers. Sort the rows so that the largest value is at 
the top, and I used conditional formatting to display data bars for the 
percentages.

In which branch do tellers open the most checking accounts for new 
customers?

Figure 20 shows a pivot table that answers this question. At the Central 
branch, tellers opened 23 checking accounts for new customers.

This pivot table uses three filters.

 ■ The Customer field is in the Filters section.

 ■ The OpenedBy field is in the Filters section.

 ■ The AcctType field is in the Filters section.

 ■ The Branch field is in the Rows section.

 ■ The Amount field is in the Values section,  
summarized by count.

The Customer field is filtered to show only New, the OpenedBy field is 
filtered to show only Teller, and the AcctType field is filtered to show 
only Checking.

Figure 20.
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